PHP4带来的痛

Category : 平凡生活 / Tags : , , / Date : 2010.04.13 / /

  上次后台升级插件时Floatbox Plus报错,也懒得在本地测试了。一时没有找到报错原因,今天升级另一个插件WP-PageNavi时又报类似的错。Google到报相同错的的文章,终于找到原因了。原来是因为这两个插件的新版都必需运行到PHP5上,而我现在的虚拟主机是PHP4环境的。Floatbox Plus只好止步于1.2.14版本, WP-PageNavi只好止步于版本2.61了,这么好两个插件在我的虚拟主机不能再更新了,真可惜!

  把报错信息放上来,提供给其它网友参考。如果你也报相同错误,多数情况就是PHP版本过低造成的不支持了。这是WP-PageNavi报的错:

Parse error: syntax error,unexpected T_STATIC,expecting T_OLD_FUNCTION or
T_FUNCTION or T_VAR or'}'in /plugins/wp-pagenavi/wp-pagenavi.php on line 179


  之前由于虚拟主机连接数的限制原因造成过几次暂时不能访问的情况,就有打算换个国外空间了(国内空间限制还挺多,总的算下来还挺贵的)。看过几个博主有推荐Site5的空间,各位看客们有更多更好的主机推荐吗?最好是支持SSH的,感謝你的留言推荐。

  Update:DB Cache Reloaded 2.1已开始转为PHP5,最后可用的PHP4版本为:2.02



无觅相关文章插件,快速提升流量

Comments

There are no comments.

Leave a Reply

You must be logged in to post a comment.

传奇 似水流年 绽放 风筝 八月照相馆